Gulpfile.js ECMA Script6(ES2015)로 작성하기

간단하게 gulp 를 ecma6 로 작성이 가능합니다.  gulp 3.9.0 버전 이상 으로 설치해주시고 babel 을 설치합니다. (gulp -v 명령을 통해 설치된 gulp 버전을 확인할 수 있습니다.)

npm install –save-dev babel

기존에 사용하던 gulpfile.js 를 gulpfile.babel.js 로 이름을 변경합니다.

기존과 같이 gulp 명령어를 사용하여 ECMA Script6로 작성된 gulpfile.js 를 실행할 수 있습니다.